Website overhaul

Questions and updates for http://www.railroadfan.com are posted here. If anyone has suggestions, either post here or email me at zack@railroadfan.com.
User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Website overhaul

Unread post by ~Z~ »

Noticed the site running overall slow on and off throughout the day for the past couple of weeks. The SQL services that run most functions of the website (message board, wiki, photo gallery) were getting hammered.
Worked with the hosting company to identify some reasons site was running slow. Made a few changes on the backend, hoping some of the changes will lessen the impact we were seeing. I have some upgrades to run later this week that will hopefully fix things a bit as well.
Webmaster
Railroad photos on Railroadfan.com

User avatar
Jetlink
Not a Railfan
Posts: 3137
Joined: Mon Jun 27, 2011 2:41 pm
Location: 2.5 miles from CH 116.3

Re: Site slow

Unread post by Jetlink »

Noticed the entire site wouldn't load around 0300 this morning. Neither the forums or the chat room.
interested in trains

User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Re: Site slow

Unread post by ~Z~ »

Running some website software upgrades today - don't be too surprised if some things temporarily break today.
Webmaster
Railroad photos on Railroadfan.com

User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Re: Site slow

Unread post by ~Z~ »

Still finishing work on bringing the site back online. Message board and wiki are up, photo gallery still needing work.
It was a long line of issues that occurred as we tried to run various software upgrades to the webhost. PHP needed updating, but before it could, Apache needed upgrading, and before that could happen, MySQL needed an overhaul. MySQL broke during the upgrade, so had to start from scratch on a clean install. Permissions messed up after that for access to the database. Message board seems to be operating correctly again at least, as is the wiki.
Apologies for the long downtime yesterday afternoon/evening and this morning.
Only part that has been upgraded so far was MySQL. Still need to do Apache and PHP, so based on yesterday, will likely have some outage times today as well. Hopefully nothing like yesterday, but we'll see.
Webmaster
Railroad photos on Railroadfan.com

User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Re: Site slow

Unread post by ~Z~ »

4:50pm update - wiki is currently down. Have the backend upgrades done, but now need to upgrade the software for the wiki and the message board. Doing a full site backup currently, and will try to work on this later tonight.
Webmaster
Railroad photos on Railroadfan.com

User avatar
Michael
Railroadfan...fan
Posts: 8535
Joined: Sun Sep 12, 2010 2:52 pm
Location: Plymouth, Michigan

Re: Site slow

Unread post by Michael »

Thanks Zack. Hard work!. I'll make sure there is a little something extra in your paycheck this week :wink:

User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Re: Site slow

Unread post by ~Z~ »

As you can tell, things look a bit different at the moment. Need to work on a few menu systems, getting a chat box up and running as well.
Webmaster
Railroad photos on Railroadfan.com

DaveO
Railroadfan...fan
Posts: 490
Joined: Thu Dec 14, 2017 1:57 pm
Location: Between here and there

Re: Site slow

Unread post by DaveO »

The icon for read and unread messages appears to be the same?
If you hover over it will does say post or unread post.

User avatar
AARR
Ann Arbor RR Nerd
Posts: 32160
Joined: Wed Dec 22, 2004 8:39 pm
Location: Washington, MI

Re: Site slow

Unread post by AARR »

Still looks very different. Everything is gray or white. No chat box. Go get em' ~Z~ :-)
PatC created a monster, 'cause nobody wants to see Don Simon no more they want AARR I'm chopped liver, well if you want AARR this is what I'll give ya, bad humor mixed with irrelevant info that'll make you roll your eyes quicker than a ~Z~ banhammer...

User avatar
Standard Railfan
Railroadfan...fan
Posts: 1507
Joined: Wed Jan 18, 2012 8:25 pm
Location: Marquette, MI

Re: Site slow

Unread post by Standard Railfan »

I like the new look!

Thank you for efforts Zack.

User avatar
Saturnalia
Authority on Cat
Posts: 13900
Joined: Wed Sep 28, 2011 7:54 pm
Location: Michigan's Copper Country
Contact:

Re: Site slow

Unread post by Saturnalia »

I also like the darker color scheme, however I definitely prefer for unread forums and threads to be a different color on their marker. The dot within the dot doesn't do it for me.

Also, is there an option to modestly raise the pixel size limits on avatars? It may be nice to have an upgrade in that department.

Thanks for keeping the site maintained :)

User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Re: Site slow

Unread post by ~Z~ »

So on the backend, a few pieces of the operating system that this site runs on were upgraded. The old version of PHP was allowing far too many "hackers" to try to bog the site down. When that version was upgraded, the message board's version was too out of date and needed upgrading. The style for the page wasn't available on the new system, so I picked this one so far. I may add a 2nd style in for people to pick from. Hang tight.

Things to fix which are progressing slowly so far:
Wikipedia - couldn't log into it to do any updates. Attempting a version upgrade. Can't upgrade yet though as part of PHP needs fixing.
Chat room - so the new version of the message board doesn't work with the old chat room. Attempting to get a new chat room installed.
Message board - will fix the icons to better display when there are new replies. There's a link under "Quick Links" at the top left corner that brings you to all the new posts. I'm going to try to figure out how to make that more prominent.
Need to add links to the wiki and the photo gallery.

Hope we'll get this all squared away soon.. much more of an endeavor than I planned.
Webmaster
Railroad photos on Railroadfan.com

User avatar
SW
Rail Trail Explorer
Posts: 10140
Joined: Tue Jul 05, 2005 10:51 pm
Location: Northville, MI - 1 mile east of MP 79 on the CSX Saginaw Sub

Re: Site slow

Unread post by SW »

Appreciate your efforts, ~Z~!
Northville Steve

User avatar
MQT1223
O Scale Railfanner
Posts: 2946
Joined: Wed Sep 10, 2014 1:46 pm
Location: Grandville, Michigan
Contact:

Re: Site slow

Unread post by MQT1223 »

This new look is a little overwhelming at the moment but very slick!
1223 OUT! President and Founder of the Buck Creek Central, the Rolling River Route! (2012-2017) President and Founder of the Lamberton Valley Railroad, The Tin Plate Road! Proudly railfanning with Asperger's since 1996. :)

User avatar
~Z~
Sofa King Admin
Posts: 10936
Joined: Tue Oct 12, 2004 2:14 pm
Location: Grand Rapids, MI
Contact:

Re: Site slow

Unread post by ~Z~ »

Updated the read/unread buttons... unread now has a bright red color on the buttons.

For the forum style, I have turned on the default style to be allowed to be picked from. You can switch from the darker color called "Carbon" to a lighter theme called "prosilver" at this link: ucp.php?i=ucp_prefs&mode=personal
Where it says "My Board Style" - use the dropdown, choose prosilver, and hit "Submit."

Chat (Shoutbox) has been installed. It's visible near the bottom on the main forum page. Trying to get links to it on the main menu for the site. You'll notice the newest posts are at the top of the chat window, instead of the bottom.

Need to fix the wiki.. currently it's just in read-only mode, and can't edit it. Trying to get the authentication between the message board user group and the wiki to work..has not gone well the few times I've tried getting that bridge working.

Search feature isn't working the best - only seeing posts from 2005 and earlier. Trying to reindex that now.
Webmaster
Railroad photos on Railroadfan.com

User avatar
Saturnalia
Authority on Cat
Posts: 13900
Joined: Wed Sep 28, 2011 7:54 pm
Location: Michigan's Copper Country
Contact:

Re: Website overhaul

Unread post by Saturnalia »

I like the red unread icons! And actually like the darker look since everything is going “dark mode” these days.

GreatLakesRailfan
Railroadfan...fan
Posts: 4718
Joined: Wed Aug 24, 2005 12:28 am
Location: Marysville, Michigan

Re: Website overhaul

Unread post by GreatLakesRailfan »

For the most part I'm only visiting the site on my phone these days. It's really nice to not have to resize my screen to read the site. :D

User avatar
Saturnalia
Authority on Cat
Posts: 13900
Joined: Wed Sep 28, 2011 7:54 pm
Location: Michigan's Copper Country
Contact:

Re: Website overhaul

Unread post by Saturnalia »

At the bottom of thread pages, can we get a link back to that forum? Sure, using the back arrow works but it doesn’t update the read/unread icons.

User avatar
Michael
Railroadfan...fan
Posts: 8535
Joined: Sun Sep 12, 2010 2:52 pm
Location: Plymouth, Michigan

Re: Website overhaul

Unread post by Michael »

Is the requirement to supply a reason for a deleting a post new ?

User avatar
Garry K
Railroadfan...fan
Posts: 826
Joined: Thu Sep 15, 2005 3:18 pm
Location: Livonia, MI

Re: Website overhaul

Unread post by Garry K »

OK, so I just switched my preferences to prosilver, and it is not much better than the default. Now (with prosilver), there is gray text on a light blue/gray background. Still not enough contrast for my old eyes to read easily.

PLEASE add an option so I can see BLACK text on a WHITE background. Thank you.

Garry K

Post Reply